Диалог выбора файла в 1С 8

Вопрос:

Расскажите как вызвать диалог выбора файла в 1С8, что б у меня в поле ввода попал полный путь к выбранному файлу.

Ответ:

В своей обработке создаешь строковый реквизит ПутьКФайлу, на форму кидаешь поле ввода с данными этого реквизита. На событие поля ввода Начало выбора создаешь такую процедуру:

Процедура ПутьКФайлуНачалоВыбора(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка= Ложь;
    если Не ВыбратьФайл(ПутьКФайлу, РежимДиалогаВыбораФайла.Открытие, "Выбор файла данных", "*.dbf") тогда
        Сообщить("Не удалось выбрать файл!");
    КонецЕсли;
КонецПроцедуры

Функция ВыбратьФайл(ПолноеИмяФайла, Режим, Заголовок, Фильтр)

    Диалог = Новый ДиалогВыбораФайла(Режим);
    Диалог.Заголовок                 = Заголовок;
    Диалог.ПредварительныйПросмотр     = Ложь;
    Диалог.Фильтр                   = Фильтр;

    Если ЗначениеЗаполнено(ПолноеИмяФайла) Тогда
        Диалог.ПолноеИмяФайла= ПолноеИмяФайла;
    КонецЕсли;

    Если Диалог.Выбрать() Тогда
        ПолноеИмяФайла= Диалог.ПолноеИмяФайла;
        Возврат Истина;
    Иначе
        Возврат Ложь;
    КонецЕсли;

КонецФункции

Вот и все, после выбора файла в реквизите ПутьКФайлу у тебя будет полный путь к нему